VS:ResetOrientation3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (make clearer)
 
(2 intermediate revisions by 2 users not shown)
Line 30: Line 30:
ResetOrientation3D;
ResetOrientation3D;
</code>
</code>
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
Line 35: Line 36:
</code>
</code>
</sample>
</sample>
-----------------------------------------------------------------------------------------------------------
<remark>
[[User: CBM-c-| _c_]]: (2021.04.11):
Used in Plug-in Object, '''ResetOrientation''' removes the rotation of a solid, if any, so be careful:
<code lang="pas">
Set3DRot(solidHandle, 0, 90, 0, 0, 0, 0);
ResetOrientation3D;
{ in PIO ResetOrientation3D removes the rotation of solidHandle! }
</code>
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from MiniCAD5.0.2
Availability: from MiniCAD 5.0.2


</version>
</version>

Latest revision as of 06:34, 11 April 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ResetOrientation3D resets the 3D environment parameters of the active VectorWorks document.

Call this procedure after 3D object creation to ensure correct orientation and display of the new object in 3D space.

PROCEDURE ResetOrientation3D;
def vs.ResetOrientation3D():
    return None

Remarks

_c_: (2021.04.11):

Used in Plug-in Object, ResetOrientation removes the rotation of a solid, if any, so be careful:

Set3DRot(solidHandle, 0, 90, 0, 0, 0, 0);
ResetOrientation3D;
{ in PIO ResetOrientation3D removes the rotation of solidHandle! }

Example

VectorScript

Poly3D(1,1,0,1.5,1.5,1,2.5,1.5,1,);
ResetOrientation3D;

Python


Version

Availability: from MiniCAD 5.0.2