VS:IsPlanarObj: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (Transfer Orso to _c_)
No edit summary
Line 33: Line 33:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
[[User:CBM-c-|_c_]] (2020.05.17)  
[[User:CBM-c-|_c_]] (2020.05.17) Renamed "NewParam" into "refID", which is the name used for this variable everywhere else.
Renamed "NewParam" into "refID", which is the name used for this variable everywhere else.
 
This function always seems to return 0 for refID, no matter where the object being tested is located.
</remark>
</remark>



Revision as of 21:27, 16 February 2023

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

FUNCTION IsPlanarObj(
object :HANDLE;
VAR refID :LONGINT) : BOOLEAN;
def vs.IsPlanarObj(object):
    return (BOOLEAN, refID)

Parameters

object HANDLE Object to test
refID LONGINT If object is planar, returns the planar refID of its plane

Remarks

_c_ (2020.05.17) Renamed "NewParam" into "refID", which is the name used for this variable everywhere else.

This function always seems to return 0 for refID, no matter where the object being tested is located.

Version

Availability: from Vectorworks 2016