VS:IsPlanarObj: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Renamed "NewParam" into "refID", which is the name used for this variable everywhere else.)
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 33: Line 33:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2020.05.17)
This function always seems to return 0 for refID, no matter which plane the object being tested is located.
Renamed "NewParam" into "refID", which is the name used for this variable everywhere else.
Use [[VS:GetPlanarRef|GetPlanarRef]] instead to find the planar refID of a given planar object.
</remark>
</remark>



Latest revision as of 15:30, 17 February 2023

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

FUNCTION IsPlanarObj(
object :HANDLE;
VAR refID :LONGINT) : BOOLEAN;
def vs.IsPlanarObj(object):
    return (BOOLEAN, refID)

Parameters

object HANDLE Object to test
refID LONGINT If object is planar, returns the planar refID of its plane

Remarks

This function always seems to return 0 for refID, no matter which plane the object being tested is located.

Use GetPlanarRef instead to find the planar refID of a given planar object.

Version

Availability: from Vectorworks 2016