VS:InsertNewComponent: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION InsertNewComponent(object:HANDLE; beforeComponentIndex:INTEGER; width:REAL; fill:LONGINT; leftPenWeight:INTEGER; rightPenWeight:INTEGER; leftPenStyle:INTEGER; rightPenStyle:INTEGER) : BOOLEAN;
FUNCTION InsertNewComponent(obj:HANDLE; beforeComponentIndex:INTEGER; width:REAL; fill:LONGINT; leftPenWeight:INTEGER; rightPenWeight:INTEGER; leftPenStyle:INTEGER; rightPenStyle:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.InsertNewComponent(object, beforeComponentIndex, width, fill, leftPenWeight, rightPenWeight, leftPenStyle, rightPenStyle):
def vs.InsertNewComponent(obj, beforeComponentIndex, width, fill, leftPenWeight, rightPenWeight, leftPenStyle, rightPenStyle):
     return BOOLEAN
     return BOOLEAN
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
Line 78: Line 78:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Latest revision as of 20:03, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Inserts a new component in an object.

FUNCTION InsertNewComponent(
obj :HANDLE;
beforeComponentIndex :INTEGER;
width :REAL;
fill :LONGINT;
leftPenWeight :INTEGER;
rightPenWeight :INTEGER;
leftPenStyle :INTEGER;
rightPenStyle :INTEGER) : BOOLEAN;
def vs.InsertNewComponent(obj, beforeComponentIndex, width, fill, leftPenWeight, rightPenWeight, leftPenStyle, rightPenStyle):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
beforeComponentIndex INTEGER The index before which to insert the new component.
width REAL The width of the component.
fill LONGINT The fill of the component. Positive values for patterns, negative ref numbers for hatches.
leftPenWeight INTEGER The pen weight of the component's left line.
rightPenWeight INTEGER The pen weight of the component's right line.
leftPenStyle INTEGER The pen style of the component's left line. Positive values for patterns, negative values for dash styles.
rightPenStyle INTEGER The pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:DeleteComponent

VS Functions: [[VS:DeleteComponent]]