VS:GetWallCompStartPts

From Vectorworks Developer
Revision as of 08:24, 4 February 2016 by CBM-c- (talk | contribs) (it doesn't accept REAL, it only takes POINT)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the start points of a wall component.

PROCEDURE GetWallCompStartPts(
wall :HANDLE;
componentIndex :INTEGER;
VAR leftPoint :POINT;
VAR centerPoint :POINT;
VAR rightPoint :POINT);
def vs.GetWallCompStartPts(wall, componentIndex):
    return (leftPoint, centerPoint, rightPoint)

Parameters

wall HANDLE The wall or round wall
componentIndex INTEGER The component index
leftPoint POINT Returns the left start point of the component
centerPoint POINT Returns the center start point of the component
rightPoint POINT Returns the right start point of the component

Return Value

None

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetWallCompEndPts

VS Functions: [[VS:GetWallCompEndPts]]