VS:GetTexSpace2DScale: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(fix)
(2 intermediate revisions by the same user not shown)
Line 31: Line 31:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2018 Dec. 29) Use [[VS:GetTexMapRealN]] instead.
Gets the 2D scale for this texture space as a multiple of a default size of 1.
Gets the 2D scale for this texture space as a multiple of a default size of 1.


Line 38: Line 40:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks8.0
Availability: from VectorWorks 8.0


</version>
</version>

Revision as of 10:15, 29 December 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTexSpace2DScale returns the 2D scale for the referenced texture space.

FUNCTION GetTexSpace2DScale(
textureSpace :HANDLE) : REAL;
def vs.GetTexSpace2DScale(textureSpace):
    return REAL

Parameters

textureSpace HANDLE Handle to texture space.

Remarks

(Orso, 2018 Dec. 29) Use VS:GetTexMapRealN instead.

Gets the 2D scale for this texture space as a multiple of a default size of 1.

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0