VS:GetTexSpace2DRadius: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(expand info)
m (Transfer Orso to _c_)
 
(One intermediate revision by the same user not shown)
Line 31: Line 31:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018. Use [[VS:GetTexMapRealN]] instead.  
[[User:CBM-c-|_c_]] (2018 Dec. 29) Use [[VS:GetTexMapRealN]] instead.  





Latest revision as of 07:40, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTexSpace2DRadius returns the radius of the referenced texture space for applicable mapping types.

FUNCTION GetTexSpace2DRadius(
textureSpace :HANDLE) : REAL;
def vs.GetTexSpace2DRadius(textureSpace):
    return REAL

Parameters

textureSpace HANDLE Handle to texture space.

Remarks

_c_ (2018 Dec. 29) Use VS:GetTexMapRealN instead.


For applicable mapping types, gets the radius of the texture space.

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0