VS:GetTexSpace2DOffset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (Transfer Orso to _c_)
 
(3 intermediate revisions by the same user not shown)
Line 41: Line 41:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
[[User:CBM-c-|_c_]], (2018.12.29) Use [[VS:GetTexMapRealN]] instead.
Gets the 2D offset for this texture space in real-world inches.
Gets the 2D offset for this texture space in real-world inches.


Line 48: Line 51:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks8.0
Availability: from VectorWorks 8.0


</version>
</version>

Latest revision as of 07:43, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetTexSpace2DOffset returns the 2D offset for the referenced texture space in real-world inches.

PROCEDURE GetTexSpace2DOffset(
textureSpace :HANDLE;
VAR offsetU :REAL;
VAR offsetV :REAL);
def vs.GetTexSpace2DOffset(textureSpace):
    return (offsetU, offsetV)

Parameters

textureSpace HANDLE Handle to texture space.
offsetU REAL Returns texture offset U component.
offsetV REAL returns texture offset V component.

Remarks

_c_, (2018.12.29) Use VS:GetTexMapRealN instead.


Gets the 2D offset for this texture space in real-world inches.

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0