VS:GetRot3D

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Obsolete procedure.

PROCEDURE GetRot3D(
h :HANDLE;
VAR xRot :REAL;
VAR yRot :REAL;
VAR zRot :REAL);
def vs.GetRot3D(h):
    return (xRot, yRot, zRot)

Parameters

h HANDLE Handle to object.
xRot REAL X rotation.
yRot REAL Y rotation.
zRot REAL Z rotation.

Remarks

Deleted this obsolete function as of 9.0.0b7 - PCP 12-21-2000


This is the old call to query 3D rotations. It was never documented & never supported returning the reflection status of the object. It has been replaced by Get3DOrientation.

Version

GetRot3D is obsolete as of VectorWorks8.0


Availability: from MiniCAD

See Also

VS Functions:

VS:Get3DOrientation

VS Functions: [[VS:Get3DOrientation]]