VS:GetPt3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
m (Transfer Orso to _c_)
 
Line 36: Line 36:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2011 Jan. 09) the z-value of the returned 3D point is always zero if  
([[User:CBM-c-|_c_]], 2011.01.09) the z-value of the returned 3D point is always zero if  
* the current view is Top-plan or Top (From Raymond Mullin).  
* the current view is Top-plan or Top (From Raymond Mullin).  
* there is no pre-existing snapped geometry in 3D (by useWPOnly = FALSE)
* there is no pre-existing snapped geometry in 3D (by useWPOnly = FALSE)

Latest revision as of 05:35, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetPt3D switches the cursor to 3D selection mode and allows the user to select a point in a VectorWorks document. This cannot be used if there is a function anywhere in the calling chain.

PROCEDURE GetPt3D(
VAR pX, pY, pZ :REAL;
useWPOnly :BOOLEAN);
def vs.GetPt3D(useWPOnly, callback):
    return None

Parameters

pX, pY, pZ REAL Returns coordinates of mouse click.
useWPOnly BOOLEAN TRUE if the returned point have to be on the active Working Plane. Snapping to arbitrary 3D geometry will produce vertical projection result on the WP; FALSE if the point can be arbitrary 3D point (produced, for example, by snapping to a 3D geometry)

Remarks

(_c_, 2011.01.09) the z-value of the returned 3D point is always zero if

  • the current view is Top-plan or Top (From Raymond Mullin).
  • there is no pre-existing snapped geometry in 3D (by useWPOnly = FALSE)

In Python this function will NOT block execution. It will execute a callback function with the resulted point (as callback function parameter).

Example

Python sample is similar to the sample in VS:GetPt.

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:GetPt | VS:GetPtL | VS:GetPt3D | VS:GetPtL3D | VS:GetLine | VS:GetLine3D | VS:GetRect | VS:GetRect3D | VS:TrackObject

VS Functions:

[[VS:GetPt]] | [[VS:GetPtL]] | [[VS:GetPt3D]] | [[VS:GetPtL3D]] | [[VS:GetLine]] | [[VS:GetLine3D]] | [[VS:GetRect]] | [[VS:GetRect3D]] |

[[VS:TrackObject]]