VS:GetPluginStyleSymbol

From Vectorworks Developer
Revision as of 06:23, 14 January 2017 by CBM-c- (talk | contribs) (fix typo)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the handle to a symbol that defines the plug-in style for a given plug-in object.

FUNCTION GetPluginStyleSymbol(
hObject :HANDLE;
VAR hSymDef :HANDLE) : BOOLEAN;
def vs.GetPluginStyleSymbol(hObject, hSymDef):
    return (BOOLEAN, hSymDef)

Parameters

hObject HANDLE Handle to a plug-in object.
hSymDef HANDLE Handle to a symbol definition that contrains the plug-in style associated with hObject.

Return Value

TRUE if the object is styled.

FALSE if the object is uynstyled.

Version

Availability: from Vectorworks 2017