VS:GetPluginStyleSymbol: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fix typo)
No edit summary
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Retrieves the handle to a symbol that defines the plug-in style for a given plug-in object.
Retrieves the handled to a symbol that defines the plug-in style for a given plug-in object.<BR>
<BR>
</desc>
</desc>


Line 31: Line 32:
hSymDef
hSymDef
HANDLE
HANDLE
Handle to a symbol definition that contrains the plug-in style associated with hObject.
Hanlde to a symbol definition that contrains the plug-in style associated with hObject.
</line>
</line>
</lineList>
</lineList>

Revision as of 18:51, 7 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the handled to a symbol that defines the plug-in style for a given plug-in object.


FUNCTION GetPluginStyleSymbol(
hObject :HANDLE;
VAR hSymDef :HANDLE) : BOOLEAN;
def vs.GetPluginStyleSymbol(hObject, hSymDef):
    return (BOOLEAN, hSymDef)

Parameters

hObject HANDLE Handle to a plug-in object.
hSymDef HANDLE Hanlde to a symbol definition that contrains the plug-in style associated with hObject.

Return Value

TRUE if the object is styled.

FALSE if the object is uynstyled.

Version

Availability: from Vectorworks 2017