VS:GetPartInstanceName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(fix declaration, the routine has been renamed (see VB-182161 and VB-183350 by R. Mullin))
Line 12: Line 12:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GePartInstanceName(objectHandle:HANDLE) : STRING;
FUNCTION GetPartInstanceName(objectHandle:HANDLE) : STRING;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GePartInstanceName(objectHandle):
def vs.GetPartInstanceName(objectHandle):
     return STRING
     return STRING
</funcDef>
</funcDef>

Revision as of 07:09, 7 January 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Return the unique name assigned to this part instance represented by the specified sub-object.

The sub-object must be an object that was tagged as a part.

FUNCTION GetPartInstanceName(
objectHandle :HANDLE) : STRING;
def vs.GetPartInstanceName(objectHandle):
    return STRING

Parameters

objectHandle HANDLE The sub-object handle.

Return Value

The unique name assigned to this part instance.

Version

Availability: from Vectorworks 2022