VS:GetLSN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fix)
m (Transfer Orso to _c_)
 
Line 32: Line 32:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]] 2016.02.29): Returns a name list index, while the older routine [[VS:GetLS]] returned a dash style index.  
[[User:CBM-c-|_c_]] (2016.02.29): Returns a name list index, while the older routine [[VS:GetLS]] returned a dash style index.  


<code lang="vs">
<code lang="vs">

Latest revision as of 06:52, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetLSN returns the line style of the referenced object.

FUNCTION GetLSN(
h :HANDLE) : LONGINT;
def vs.GetLSN(h):
    return LONGINT

Parameters

h HANDLE Handle to object.

Remarks

_c_ (2016.02.29): Returns a name list index, while the older routine VS:GetLS returned a dash style index.

styleName := Index2Name(-GetLSN(FSActLayer));
{ returns the name of the dash style defintion of the first selected object }

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:SetLSN

VS Functions: [[VS:SetLSN]]