VS:GetDistanceAlongNurbsCurve

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets distance between a point at parameter1 on the curve piece index1 and another point at parameter2 on the curve piece with index2

FUNCTION GetDistanceAlongNurbsCurve(
inNurbsCurve :HANDLE;
inParamter1 :REAL;
inParameter1index :LONGINT;
inParamter2 :REAL;
inParameter2index :LONGINT;
VAR outDistance :REAL)Coordinate)) : BOOLEAN;
def vs.GetDistanceAlongNurbsCurve(inNurbsCurve, inParamter1, inParameter1index, inParamter2, inParameter2index):
    return (BOOLEAN, outDistance)

Parameters

inNurbsCurve HANDLE
inParamter1 REAL
inParameter1index LONGINT
inParamter2 REAL
inParameter2index LONGINT
outDistance REAL (Coordinate)

Remarks

if there is only one piece in the inNurbsCurve, both inParameter1index and inParameter2index should be 0.

Version

Availability: from VectorWorks10.0