VS:GetComponentWidth

From Vectorworks Developer
Revision as of 19:53, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the width of a component in an object.

FUNCTION GetComponentWidth(
obj :HANDLE;
componentIndex :INTEGER;
VAR width :REAL) : BOOLEAN;
def vs.GetComponentWidth(obj, componentIndex):
    return (BOOLEAN, width)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
width REAL Returns the width of the component.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:SetComponentWidth

VS Functions: [[VS:SetComponentWidth]]