VS:GetComponentFollowBottomWallPeaks: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentFollowBottomWallPeaks(object:HANDLE; componentIndex:INTEGER; VAR followBottomWallPeaks:BOOLEAN) : BOOLEAN;
FUNCTION GetComponentFollowBottomWallPeaks(obj:HANDLE; componentIndex:INTEGER; VAR followBottomWallPeaks:BOOLEAN) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentFollowBottomWallPeaks(object, componentIndex):
def vs.GetComponentFollowBottomWallPeaks(obj, componentIndex):
     return (BOOLEAN, followBottomWallPeaks)
     return (BOOLEAN, followBottomWallPeaks)
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.

Latest revision as of 19:47, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the follow bottom wall peaks flag of a component in an object.

FUNCTION GetComponentFollowBottomWallPeaks(
obj :HANDLE;
componentIndex :INTEGER;
VAR followBottomWallPeaks :BOOLEAN) : BOOLEAN;
def vs.GetComponentFollowBottomWallPeaks(obj, componentIndex):
    return (BOOLEAN, followBottomWallPeaks)

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
followBottomWallPeaks BOOLEAN Returns whether or not the component is following bottom wall peaks.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentFollowBottomWallPeaks

VS Functions: [[VS:SetComponentFollowBottomWallPeaks]]