VS:GetComponentFillColors

From Vectorworks Developer
Revision as of 19:46, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the fore and back fill colors of a component in an object.

FUNCTION GetComponentFillColors(
obj :HANDLE;
componentIndex :INTEGER;
VAR fillForeColor :INTEGER;
VAR fillBackColor :INTEGER) : BOOLEAN;
def vs.GetComponentFillColors(obj, componentIndex):
    return (BOOLEAN, fillForeColor, fillBackColor)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
fillForeColor INTEGER Returns the fore color of the fill.
fillBackColor INTEGER Returns the back color of the fill.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentFillColors

VS Functions: [[VS:SetComponentFillColors]]