VS:GetClLSN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(correction)
m (Transfer Orso to _c_)
 
(One intermediate revision by the same user not shown)
Line 33: Line 33:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]] 2016.02.29): Returns a name list index, while the older routine [[VS:GetClLS]] returned a dash style index.  
[[User:CBM-c-|_c_]] (2016.02.29): Returns a name list index, while the older routine [[VS:GetClLS]] returned a dash style index.  


<code lang="vs">
<code lang="vs">
indx := GetClLSN('None');
indx := GetClLSN('None');
IF indx < 0 THEN { if the index is positive then is a pattern. Patterns are not named resources }
IF indx < 0 THEN { if the index is positive then is a pattern. Patterns are not named resources }
Message(Index2Name(-GetClLSN('None'))); { returns the name of the dash style attached to the class 'None', if any }
Message(Index2Name(-indx)); { returns the name of the dash style attached to the class 'None', if any }
</code>
</code>
</remark>
</remark>

Latest revision as of 06:55, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the line style of the specified class.

FUNCTION GetClLSN(
className :STRING) : LONGINT;
def vs.GetClLSN(className):
    return LONGINT

Parameters

className STRING Name of class.

Remarks

_c_ (2016.02.29): Returns a name list index, while the older routine VS:GetClLS returned a dash style index.

indx := GetClLSN('None');
IF indx < 0 THEN { if the index is positive then is a pattern. Patterns are not named resources }
	Message(Index2Name(-indx)); { returns the name of the dash style attached to the class 'None', if any }

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:SetClLSN

VS Functions: [[VS:SetClLSN]]