VS:GetBBox

From Vectorworks Developer
Revision as of 06:21, 30 December 2020 by CBM-c- (talk | contribs) (Transfer Orso to _c_)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetBBox returns the bounding box of the projection of the referenced object on the screen plane.

PROCEDURE GetBBox(
h :HANDLE;
VAR p1X,p1Y :REAL;
VAR p2X,p2Y :REAL);
def vs.GetBBox(h):
    return (p1, p2)

Parameters

h HANDLE Handle to object.
p1 REAL Top left coordinate of bounding box.
p2 REAL Bottom right coordinate of bounding box.

Remarks

_c_, 2017.02.24: GetBBox fails unpredictably on Roof faces when in top-plan: it returns a bounding box dependent on the axis widget and the page position of the face. Avoid the axis widget setting the view to Top, then the returned values will be correct. This is valid up to VW 2017 (bug reported).

Version

Availability: from All Versions