VS:FlipHybMatrixObj: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
m (Transfer Orso to _c_)
 
Line 39: Line 39:
From Vectorworks 2017 it flips object with any rotation.
From Vectorworks 2017 it flips object with any rotation.


([[User:Orso.b.schmid|Orso]] 2015.12.09):  
([[User:CBM-c-|_c_]] 2015.12.09):  


Started from VWPluginLibraryRoutines.h VW12.
Started from VWPluginLibraryRoutines.h VW12.
Line 45: Line 45:
Warning: it only works on symbols or plug-ins whose rotation is 0 or -180. Objects on drawing with any other rotation are ignored.
Warning: it only works on symbols or plug-ins whose rotation is 0 or -180. Objects on drawing with any other rotation are ignored.


([[User:Orso.b.schmid|Orso]] 2008.05.11):  
([[User:CBM-c-|_c_]] 2008.05.11):  


Flips hybrid objects: symbols and plug-ins. If the objects to flip are symbols you must coerce a redraw for the flip to be visible.
Flips hybrid objects: symbols and plug-ins. If the objects to flip are symbols you must coerce a redraw for the flip to be visible.

Latest revision as of 05:10, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

inFlipSpecifier = 0 for flipH, inFlipSpecifier = 1 for FlipV

PROCEDURE FlipHybMatrixObj(
ioHybMatObj :HANDLE;
inFlipSpecifier :INTEGER);
def vs.FlipHybMatrixObj(ioHybMatObj, inFlipSpecifier):
    return None

Parameters

ioHybMatObj HANDLE
inFlipSpecifier INTEGER

Remarks

(Yordan 2016.14.09):

From Vectorworks 2017 it flips object with any rotation.

(_c_ 2015.12.09):

Started from VWPluginLibraryRoutines.h VW12.

Warning: it only works on symbols or plug-ins whose rotation is 0 or -180. Objects on drawing with any other rotation are ignored.

(_c_ 2008.05.11):

Flips hybrid objects: symbols and plug-ins. If the objects to flip are symbols you must coerce a redraw for the flip to be visible.

FlipHybMatrixObj(FSActLayer, 0); { FSActLayer is a symbol on drawing }
RedrawAll;

Version

Availability: from Vectorworks 2014