VS:EqPt2D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(ix)
 
(6 intermediate revisions by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns TRUE if the 2D points are equal within the tolerance.
Returns TRUE if the 2D points are equal within the tolerance</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION EqPt2D(pt1X, pt1Y, pt1Z :REAL; pt2X, pt2Y, pt2Z :REAL; tolerance :REAL) :BOOLEAN;
FUNCTION EqPt2D(pt1:VECTOR; pt2:VECTOR; tolerance:REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 23: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
pt1X, pt1Y, pt1Z
pt1
REAL
VECTOR


</line>
</line>
<line>
<line>
pt2X, pt2Y, pt2Z
pt2
REAL
VECTOR


</line>
</line>
Line 39: Line 38:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:CBM-c-|_c_]], 2022.01.21) :
* Python: contrary to most Pascal-derived vectorial routines, it accepts also a bidimensional tuple without returning gibberish: the third item will always be ignored.
* Python and Pascal: Don't pass 0 to the tolerance, or the routine will always return false.


</remark>
</remark>
Line 53: Line 50:
<sample>
<sample>


==== Vectorscript ====
<code lang="pas">
PROCEDURE Example;
VAR
    v1, v2 : VECTOR;
BEGIN
    v1.x := 12; v1.y := 1;
    v2.x := 12; v2.y := 1;
    Message(Concat( EqPt2D(v1, v2, 0.1) )); {True }
END;
Run(Example);
</code>
==== Python ====
<code lang="py">
v1 = (12, 1, 987) # 3-dimensional tuples: the 3rd item will be ignored
v2 = (12, 1, 0)
vs.Message( str(vs.EqPt2D(v1, v2, 0.1)) ) # True
</code>
</sample>
</sample>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
VS Functions:
* [[VS:EqualPt]]
* [[VS:EqPt]]
* [[VS:EqPt3D]]
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Latest revision as of 04:32, 22 January 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns TRUE if the 2D points are equal within the tolerance

FUNCTION EqPt2D(
pt1 :VECTOR;
pt2 :VECTOR;
tolerance :REAL) : BOOLEAN;
def vs.EqPt2D(pt1, pt2, tolerance):
    return BOOLEAN

Parameters

pt1 VECTOR
pt2 VECTOR
tolerance REAL

Remarks

(_c_, 2022.01.21) :

  • Python: contrary to most Pascal-derived vectorial routines, it accepts also a bidimensional tuple without returning gibberish: the third item will always be ignored.
  • Python and Pascal: Don't pass 0 to the tolerance, or the routine will always return false.

Example

Vectorscript


PROCEDURE Example;
VAR
    v1, v2 : VECTOR;
BEGIN
    v1.x := 12; v1.y := 1; 
    v2.x := 12; v2.y := 1;
    Message(Concat( EqPt2D(v1, v2, 0.1) )); {True }
END;
Run(Example);

Python

v1 = (12, 1, 987) # 3-dimensional tuples: the 3rd item will be ignored
v2 = (12, 1, 0)
vs.Message( str(vs.EqPt2D(v1, v2, 0.1)) ) # True

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS Functions:
  • [[VS:EqualPt]]
  • [[VS:EqPt]]
  • [[VS:EqPt3D]]