VS:EqPt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(add example, comment)
Line 40: Line 40:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:CBM-c-|_c_]], 2022.01.21) In Python, contrary to most Pascal-derived vectorial routines, it accepts also a bidimensional tuple without returning gibberish: the third item will always be ignored. So this is a 2D-only routine.
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
<code lang="pas">
PROCEDURE Example;
VAR
    v1, v2 : VECTOR;
BEGIN
    v1.x := 12; v1.y := 1; { z vals in 3-dimensional vectors will be ignored }
    v2.x := 12; v2.y := 1;
    Message(Concat( EqPt(v1, v2, 0) ));
END;
Run(Example);
</code>
 
<code lang="py">
v1 = (12, 1, 999) # z vals in 3-dimensional vectors will be ignored
v2 = (12, 1, 0)
vs.Message( str(vs.EqualPt(v1, v2, 0)) ) # surprisingly returns true in spite of the tuples being different, because the third item will be ignored.
</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 08:02, 21 January 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns TRUE if the 2D points are equal within the tolerance.

FUNCTION EqPt(
pt1 :VECTOR;
pt2 :VECTOR;
tolerance :REAL) : BOOLEAN;
def vs.EqPt(pt1, pt2, tolerance):
    return BOOLEAN

Parameters

pt1 VECTOR
pt2 VECTOR
tolerance REAL

Remarks

(_c_, 2022.01.21) In Python, contrary to most Pascal-derived vectorial routines, it accepts also a bidimensional tuple without returning gibberish: the third item will always be ignored. So this is a 2D-only routine.

Example

PROCEDURE Example;
VAR
    v1, v2 : VECTOR;
BEGIN
    v1.x := 12; v1.y := 1; { z vals in 3-dimensional vectors will be ignored }
    v2.x := 12; v2.y := 1;
    Message(Concat( EqPt(v1, v2, 0) ));
END;
Run(Example);
v1 = (12, 1, 999) # z vals in 3-dimensional vectors will be ignored
v2 = (12, 1, 0)
vs.Message( str(vs.EqualPt(v1, v2, 0)) ) # surprisingly returns true in spite of the tuples being different, because the third item will be ignored.

Version

Availability: from Vectorworks 2014