VS:DeleteComponent: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(shorten 'object' (reserved word), add remark about roof styles on VW 2016)
m (Transfer Orso to _c_)
 
Line 36: Line 36:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>[[User:Orso.b.schmid| Orso]]: (2016.02.03):  Supports also Roof and Roof Styles components from VW 2016.
<remark>[[User:CBM-c-|_c_]]: (2016.02.03):  Supports also Roof and Roof Styles components from VW 2016.
</remark>
</remark>



Latest revision as of 06:33, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deletes a component in an object.

FUNCTION DeleteComponent(
obj :HANDLE;
componentIndex :INTEGER) : BOOLEAN;
def vs.DeleteComponent(obj, componentIndex):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component to delete.

Remarks

_c_: (2016.02.03): Supports also Roof and Roof Styles components from VW 2016.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:InsertNewComponent

VS Functions: [[VS:InsertNewComponent]]