VS:CrossProduct

From Vectorworks Developer
Revision as of 05:26, 20 January 2022 by CBM-c- (talk | contribs) (add note about returned var dimension)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the cross product of the two specified vectors.

The cross product is also known as the vector product of the two vectors. The result is a vector whose magnitude is equivalent to the product of the magnitudes of the two vectors multiplied by the sine of the smaller angle between the two vectors. The direction of the resultant vector is perpendicular to a plane formed by the two source vectors.

FUNCTION CrossProduct(
v1 :VECTOR;
v2 :VECTOR) : VECTOR;
def vs.CrossProduct(v1, v2):
    return VECTOR

Parameters

v1 VECTOR Source vector 1.
v2 VECTOR Source vector 2.

Return Value

Returns a VECTOR which is the cross product of v1 and v2.

Remarks

(_c_, 2022.01.20) The vector returned is always 3-dimensional: Pascal: vector {x, y, z}, Python: tuple (0.0, 0.0, 0.0)


Ptr [2021.05.12]: Since in Python a VECTOR doesn't exist, you need to use tuples instead.

older posts whose author got lost:

This is provided for cross-platform compatibility.

To elaborate a little... The first vector defines the X axis of a new coordinate system; the second vector defines the positive Y direction in that coordinate system. The cross product of those vectors will be in the positive Z direction.

Version

Availability: from VectorWorks 8.5