VS:CreateTaperedExtrude

From Vectorworks Developer
Revision as of 07:23, 10 February 2016 by CBM-c- (talk | contribs) (fails creating only nurbs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new tapered extrude object in the document.

FUNCTION CreateTaperedExtrude(
profileH :HANDLE;
angle :REAL;
height :REAL) : HANDLE;
def vs.CreateTaperedExtrude(profileH, angle, height):
    return HANDLE

Parameters

profileH HANDLE Handle to object defining profile geometry.
angle REAL Taper angle of extrude (in degrees).
height REAL Height of extrude.

Return Value

Returns a HANDLE to the new tapered extrude if successful, otherwise returns NIL.

Remarks

(Orso, 2016.02.10): This always fails creating a number of NURBS instead of a tapered extrude. From VW 2016 you can use VS:CreateTaperedExtrd2.

Version

Availability: from VectorWorks 9.0