VS:CreateTaperedExtrude: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(fails creating only nurbs)
(One intermediate revision by one other user not shown)
Line 39: Line 39:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>
([[User:Orso.b.schmid|Orso]], 2016.02.10):  This always fails creating a number of NURBS instead of a tapered extrude. From VW 2016 you can use [[VS:CreateTaperedExtrd2]].
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 46: Line 51:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks9.0
Availability: from VectorWorks 9.0


</version>
</version>

Revision as of 07:23, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new tapered extrude object in the document.

FUNCTION CreateTaperedExtrude(
profileH :HANDLE;
angle :REAL;
height :REAL) : HANDLE;
def vs.CreateTaperedExtrude(profileH, angle, height):
    return HANDLE

Parameters

profileH HANDLE Handle to object defining profile geometry.
angle REAL Taper angle of extrude (in degrees).
height REAL Height of extrude.

Return Value

Returns a HANDLE to the new tapered extrude if successful, otherwise returns NIL.

Remarks

(Orso, 2016.02.10): This always fails creating a number of NURBS instead of a tapered extrude. From VW 2016 you can use VS:CreateTaperedExtrd2.

Version

Availability: from VectorWorks 9.0