VS:CreateBorderlessMenu

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a borderless menu button control in a dialog layout.

PROCEDURE CreateBorderlessMenu(
dialogID :LONGINT;
itemID :LONGINT;
label :DYNARRAY[] of CHAR;
iconResPath :DYNARRAY[] of CHAR);
def vs.CreateBorderlessMenu(dialogID, itemID, label, iconResPath):
    return None

Parameters

dialogID LONGINT The ID of the dialog
itemID LONGINT The ID of the control
label DYNARRAY[] of CHAR Label of the button. If the label is empty, this button will be a small untitled borderless menu button.
iconResPath DYNARRAY[] of CHAR The resource path of the icon

Version

Availability: from Vectorworks 2024