VS:ClipSurfaceN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (fix size)
No edit summary
Line 37: Line 37:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
[[ptr]]: (2022.05.09):
This command deletes the s1 object but not the s2 object.
[[User: CBM-c-| _c_]]: (2021.03.05):
[[User: CBM-c-| _c_]]: (2021.03.05):
This clips only parts that intersect the sides of the clipper, it doesn't clip inside the clipper, probably because it would mean deleting geometry.
This clips only parts that intersect the sides of the clipper, it doesn't clip inside the clipper, probably because it would mean deleting geometry.

Revision as of 11:18, 9 May 2023

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new surface object by subtracting the intersection of surfaces s1 and s2 from s1.

FUNCTION ClipSurfaceN(
s1 :HANDLE;
s2 :HANDLE) : HANDLE;
def vs.ClipSurfaceN(s1, s2):
    return HANDLE

Parameters

s1 HANDLE Surface to be subtracted from
s2 HANDLE Surface to subtract from s1

Remarks

ptr: (2022.05.09):

This command deletes the s1 object but not the s2 object. _c_: (2021.03.05): This clips only parts that intersect the sides of the clipper, it doesn't clip inside the clipper, probably because it would mean deleting geometry.

Example:

Version

Availability: from Vectorworks 2016