VS:CallToolByIndex: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (add link to flags in the appendix)
m (add see also)
 
Line 50: Line 50:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>
<seeAlso>
VS Functions:
* [[VS:CallTool]]
* [[VS:CallToolByName]]
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 05:19, 19 January 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Similar to CallTool. Takes the internal ID of a tool ( Appendix )

FUNCTION CallToolByIndex(
toolIndex :INTEGER) : BOOLEAN;
def vs.CallToolByIndex(toolIndex):
    return BOOLEAN

Parameters

toolIndex INTEGER

Example

Vectorscript

Message( CallToolByIndex( -221 ) ) { activate locus tool, returns true if successful }

Python

vs.Message( vs.CallToolByIndex( -221 ) ) # activate locus tool, returns true if successful

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS Functions:
  • [[VS:CallTool]]
  • [[VS:CallToolByName]]