VS:CallToolByIndex: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(add examples)
m (add link to flags in the appendix)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Similar to CallTool. Takes the internal ID of a tool.</desc>
Similar to CallTool. Takes the internal ID of a tool ([[VS:Function_Reference_Appendix#settool| Appendix]] )
 
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 05:05, 19 January 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Similar to CallTool. Takes the internal ID of a tool ( Appendix )

FUNCTION CallToolByIndex(
toolIndex :INTEGER) : BOOLEAN;
def vs.CallToolByIndex(toolIndex):
    return BOOLEAN

Parameters

toolIndex INTEGER

Example

Vectorscript

Message( CallToolByIndex( -221 ) ) { activate locus tool, returns true if successful }

Python

vs.Message( vs.CallToolByIndex( -221 ) ) # activate locus tool, returns true if successful

Version

Availability: from Vectorworks 2014