VS:Ang2Vec: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fix documentation, bug report VB-184785)
(Simplify)
 
Line 40: Line 40:
<remark>
<remark>


([[User:CBM-c-|_c_]], 2022.01.19) The vector returned is always 3-dimensional -in Pascal in the form {0, 0, 0}, in Python as tuple in the form (0, 0, 0)- whereby the last item is always 0.
([[User:CBM-c-|_c_]], 2022.01.20) The vector returned is always 3-dimensional whereby the last item is always 0: Pascal: {x, y, z}, Python: tuple (0.0, 0.0, 0.0)
</remark>
</remark>



Latest revision as of 05:24, 20 January 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a 3-dimensional vector that is defined by the specified polar angle and length values.

FUNCTION Ang2Vec(
angleR :REAL;
Length :REAL) : VECTOR;
def vs.Ang2Vec(angleR, Length):
    return VECTOR

Parameters

angleR REAL The angle of the vector (in degrees).
Length REAL The length of the vector.

Return Value

Returns a 3-dimensional vector.

Remarks

(_c_, 2022.01.20) The vector returned is always 3-dimensional whereby the last item is always 0: Pascal: {x, y, z}, Python: tuple (0.0, 0.0, 0.0)

Example

VectorScript

Message( Ang2Vec(45, 1) ); { 3-dimensional vector whose z item is always 0 }

Python

v = vs.Ang2Vec(45, 1)
vs.Message( str( v ) ) # 3-dimensional tuple whose last item is always 0

Version

Availability: from All Versions