VCOM:VectorWorks:Workspaces:IWorkspaces::GetDisplayName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaces

Gets the item's display/localized name given the Workspace Identifier.

virtual VCOMError VCOM_CALLTYPE GetDisplayName(
const TXString& inIdentifier,
TXString& outDisplayName) = 0;

Parameters

inIdentifier const TXString& No information.
outDisplayName TXString& Output parameter. No information.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.