VCOM:VectorWorks:Workspaces:IWorkspaces::CreateIdentifierUsingUniversalName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaces

Using the given Universal Name, creates the workspace identifier.

virtual VCOMError VCOM_CALLTYPE CreateIdentifierUsingUniversalName(
EWorkspaceItemType inItemType,
const TXString& inUniversalName,
TXString& outIdentifier) = 0;

Parameters

inItemType EWorkspaceItemType This is either a Menu Item or Tool. No other workspace item type requires such identifiers.
inUniversalName const TXString& This is the universal name for the workspace item.
outIdentifier TXString& Output parameter. If successful, the workspace identifier.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.