VCOM:VectorWorks:Workspaces:IWorkspaces::CreateIdentifierUsingResourceID

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaces

Using the given Resource Manager ID, creates the workspace identifier.

virtual VCOMError VCOM_CALLTYPE CreateIdentifierUsingResourceID(
EWorkspaceItemType inItemType,
Sint16 inResourceID,
TXString& outIdentifier) = 0;

Parameters

inItemType EWorkspaceItemType This is either a Menu Item, Menu Chunk, or Tool. No other workspace item type requires such identifiers.
inResourceID Sint16 This is the internal resource id (a negative number).
outIdentifier TXString& Output parameter. If successful, the workspace identifier.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.