VCOM:VectorWorks:Workspaces:IWorkspaces::CreateIdentifier

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaces

Using the given workspace item type, creates a unique workspace identifier.

virtual VCOMError VCOM_CALLTYPE CreateIdentifier(
EWorkspaceItemType inItemType,
TXString& outIdentifier) = 0;

Parameters

inItemType EWorkspaceItemType This is either a Menu, Menu Chunk, Tool Palette, or Tool Set. No other workspace item type requires such identifiers.
outIdentifier TXString& Output parameter. If successful, the workspace identifier.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.