VCOM:VectorWorks:Workspaces:IWorkspaces::ConvertSafeXMLFormatToString

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaces

Converts a xml-safe string to its original, normalized state.

virtual VCOMError VCOM_CALLTYPE ConvertSafeXMLFormatToString(
TXString& ioString) = 0;

Parameters

ioString TXString& on input, the xml-safe string, on output, the normalized string.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.