VCOM:VectorWorks:Workspaces:IWorkspaceVisualizationPalette::SetActivePanel

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceVisualizationPalette

Sets the active panel index.

virtual VCOMError VCOM_CALLTYPE SetActivePanel(
Sint16 inPanelIndex) = 0;

Parameters

inPanelIndex Sint16 the index of the panel that is to be saved as active.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

Panel index:

  • Light = 0
  • Camera = 1