VCOM:VectorWorks:Workspaces:IWorkspaceMenuItem::GetShortcutKeyInfo

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceMenuItem

Set the shortcut key information for this menu item. This will delete any submenu information as well as chunk status.

virtual VCOMError VCOM_CALLTYPE GetShortcutKeyInfo(
char& outShortcutKey,
Uint32& outShortcutKeyModifiers) = 0;

Parameters

outShortcutKey char& on output, if successful, the short cut key that will activate this menu item. May be NULL if the client is not interested in the data.
outShortcutKeyModifiers Uint32& on output, if successful, the accompanying necessary modifier keys required to activate this menu item. May be NULL if the client is not interested in the data.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.