VCOM:VectorWorks:Workspaces:IWorkspaceMenuBar

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Interface

class IWorkspaceMenuBar : public IVWUnknown
{
public:
  virtual VCOMError VCOM_CALLTYPE AddMenu(IWorkspaceMenu* inMenu) = 0;
  virtual VCOMError VCOM_CALLTYPE GetMenuCount(Sint16& outMenuCount) = 0;
  virtual VCOMError VCOM_CALLTYPE GetMenuAtIndex(Sint16 inIndex, IWorkspaceMenu** outMenu) = 0;
  virtual VCOMError VCOM_CALLTYPE GetLastError(EWorkspacesError& outError) = 0;
};

Members

AddMenu Adds a menu to this menu bar.
GetMenuCount Gets the count of menus in the menu bar.
GetMenuAtIndex Gets menu at the given index.
GetLastError Gets the last error that was generated by the IWorkspaces interface.

Version

Available from: VectorWorks 12

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:Workspaces:IWorkspaces

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:Workspaces:IWorkspaces]]