VCOM:VectorWorks:Workspaces:IWorkspaceFile::SetApplicationOrMonitorRect

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Sets a set of dimensions that represent either the Application Frame (for Windows) or the size of the Main Display (for Macintosh).

virtual VCOMError VCOM_CALLTYPE SetApplicationOrMonitorRect(
Sint16 inTop,
Sint16 inLeft,
Sint16 inWidth,
Sint16 inHeight) = 0;

Parameters

inTop Sint16 the top of the frame in relation to the Monitor (for Mac, this will always be 0).
inLeft Sint16 the left of the frame in relation to the Monitor (for Mac, this will always be 0).
inWidth Sint16 the width of the Application Frame or Monitor.
inHeight Sint16 the height of the Application Frame or Monitor.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.