VCOM:VectorWorks:Workspaces:IWorkspaceFile::Open

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Open.

virtual VCOMError VCOM_CALLTYPE Open(
const TXString& inWorkspaceFileToOpen,
long inPermissions) = 0;

Parameters

inWorkspaceFileToOpen const TXString& This is the name of the workspace file that VectorWorks open.
inPermissions long This is the read/write permission bits that should be used to open the workspace file.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.