VCOM:VectorWorks:Workspaces:IWorkspaceFile::GetToolPaletteCount

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Gets the count of tool palettes in the workspace.

virtual VCOMError VCOM_CALLTYPE GetToolPaletteCount(
Sint16& outCount) = 0;

Parameters

outCount Sint16& on output, if successful, the number of tool palettes in the workspace.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.