VCOM:VectorWorks:Workspaces:IWorkspaceFile::GetShortcutKeys

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Gets the various shortcut keys for the workspace. Any parameter may be NULL if the client is not interested in a specific piece of data. The display string for the keycodes returned in outSpecialKeys and outConstraintsKeys can be converted into an equivalent string form with the GetKeyDisplayString function.

virtual VCOMError VCOM_CALLTYPE GetShortcutKeys(
TSpecialKeys& outSpecialKeys,
TConstraintsKeys& outConstraintsKeys) = 0;

Parameters

outSpecialKeys TSpecialKeys& on output, if successful, the mode bar keys (such as enter/exit group, mode bar button iteration, etc)
outConstraintsKeys TConstraintsKeys& on output, if successful, the shortcut keys to toggle the various constraints on or off.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.