VCOM:VectorWorks:Workspaces:IWorkspaceFile::GetMenuUsingIdentifier

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Gets the menu that corresponds to the given identifier.

virtual VCOMError VCOM_CALLTYPE GetMenuUsingIdentifier(
const TXString& inIdentifier,
IWorkspaceMenu** outMenu) = 0;

Parameters

inIdentifier const TXString& the identifier that represents the desired menu.
outMenu IWorkspaceMenu** on output, if successful, a pointer to the menu.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.