VCOM:VectorWorks:Workspaces:IWorkspaceFile::GetLastError

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Gets the last error that was generated by the IWorkspaces interface.

virtual VCOMError VCOM_CALLTYPE GetLastError(
EWorkspacesError& outError) = 0;

Parameters

outError EWorkspacesError& Output parameter. Return the last error that occurred. Any successful call to a IWorkspaces function will reset this to EWorkspaces_NoError.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.