VCOM:VectorWorks:Workspaces:IWorkspaceFile::GetApplicationOrMonitorRect

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Gets a set of dimensions that represent either the Application Frame (for Windows) or the size of the Main Display (for Macintosh).

virtual VCOMError VCOM_CALLTYPE GetApplicationOrMonitorRect(
Sint16& outTop,
Sint16& outLeft,
Sint16& outWidth,
Sint16& outHeight) = 0;

Parameters

outTop Sint16& Output parameter. the top of the frame in relation to the Monitor (for Mac, this will always be 0).
outLeft Sint16& Output parameter. the left of the frame in relation to the Monitor (for Mac, this will always be 0).
outWidth Sint16& Output parameter. the width of the Application Frame or Monitor.
outHeight Sint16& Output parameter. the height of the Application Frame or Monitor.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.