VCOM:VectorWorks:Workspaces:IWorkspaceFile::CreateMenuItem

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Creates a new menu item in the workspace that can be added to a menu if it does not yet exist.

virtual VCOMError VCOM_CALLTYPE CreateMenuItem(
const TXString& inIdentifier,
IWorkspaceMenuItem** outMenuItem) = 0;

Parameters

inIdentifier const TXString& the identifier to be used to represent this menu item. Use the IWorkspaces interface to create this identifier.
outMenuItem IWorkspaceMenuItem** Output parameter. will be a newly created IWorkspaceMenuItem* on output.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.