VCOM:VectorWorks:Workspaces:IWorkspaceFile::CreateMenuChunk

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Creates a new menu chunk in the workspace that can be added to a menu if it does not yet exist.

virtual VCOMError VCOM_CALLTYPE CreateMenuChunk(
const TXString& inIdentifier,
EWorkspaceMenuChunkType inChunkType,
IWorkspaceMenuChunk** outMenuChunk) = 0;

Parameters

inIdentifier const TXString& the identifier to be used to represent this menu chunk. Use the IWorkspaces interface to create this identifier.
inChunkType EWorkspaceMenuChunkType is the type of chunk menu item to create.
outMenuChunk IWorkspaceMenuChunk** Output parameter. will be a newly created IWorkspaceMenuChunk* on output.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.