VCOM:VectorWorks:Workspaces:IWorkspaceFile::CreateMenu

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Gets the menu, or if it does not exist, creates a new menu in the Workspace that can be referrenced either by the Menu Bar or a Menu Item or as a Menu Chunk.

virtual VCOMError VCOM_CALLTYPE CreateMenu(
const TXString& inIdentifier,
IWorkspaceMenu** outMenu) = 0;

Parameters

inIdentifier const TXString& the identifier to be used to represent this menu. Use the IWorkspaces interface to create this identifier.
outMenu IWorkspaceMenu** on ouput, if successful a workspace menu VCOM interface.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.